Texecom Upgrade to Premier/Ricochet

Hi Guys, looking for some assistance...this one is very different from my old veritas system I just removed :(

So I've wired in my kepad and bellbox...wanted to install the wireless detectors only this weekend and then move on to any hardwired devices like my smoke detectors and some hardwired contacts in the garage next weekend once I know the wireless side is working as it should.

So I power up and after loading defaults it goes into alarm. I can silence no problem then it gives me the list of problems. I think one of these problems is stopping me getting into the engineers setup as I can't seem to do anything once I input the engineers code.

My alarms are as follows..

EXP 1,1 Tamper Area A
Zones 1 -8 Tamper
Alarm from zones 1 - 8 Active
Call ARC
Confirm devices

I understand the EXP 1,1 is an expander but what? I only have the main panel and 1 keypad installed.

As I say, I cannot access the engineers setup to have a look around.

Thanks for any help, I'll keep trying :LOL:

Sponsored Links
first thing whatpanel do you have ? is it a 48 plastic wireless or a 48 metal wireless kit ? link out all the zones inc tamper are you in engineer mode ? enter eng code it may say user needed enter user code it may now say allow eng access press yes then enter engineer code. do you have wintex and a pc comm ?
Hi Sparky

Yes sorry it is the 48 W plastic.

I linked out Bell tamper, Aux Tamper and the panel tamper before turning on power and doing default startup.

Those errors appear when panel boots up and I can silence them with default eng code 1234 but can't seem to go any further to get into the programming menus.

I have the Elite USB com but haven't connected it yet. I downloaded the Ricochet monitor software also.

I've had it powered down for an hour so will go start up again now.

Sponsored Links
Hi Sparky, got Wintex installed and I'm connected to the panel...What should I be looking for apart from the red buttons showing me in alarm :LOL:

right a couple of things first go to global / config and untick 10,34,37 options save and send for a start, then go to zones and make all zones by drop down box unused , save then send to control panel. this should clear all zone faults. do you have a jumper link if so fit it on the tamper disable link on the pcb as i think the exp tamp 1,1 may be the lid on the panel
Just having a look through wintex and notice it says "Expander Box Tamper Open" but unless it is refering to something else, I don't have an expander added. Also says supply voltage 21.50v - did I not read somewhere on this forum about an unusually high voltage and that wintex software is out of date? Got this one from CD supplied.

then exit engineer it should be all clear , go to send and update time and date, enter engineer code go to engineer utills config radio/ it will say press yes get your device eg pir hold down the button and pull out the battery plastic divider and after a couple of secounds it will say device found and show the code address in the display you can then go down to zone and alter the zone number for that device eg front door contact zone 1, this will map the device to zone 1 you can then go back into zones and make it entry exit and so on. ok ?
Thanks Sparky, all ok except the EXP 1,1 Tamper. I have a jumper link on the panels tamper pins, earlier I had a bit tape on the switch to keep it closed but still got the error.

I've removed the jumper from the lid tamper, replaced the lid making sure I heard the tamper click as it closed and I still get EXP 1,1 tamper.

Going to check everything again.

not too sure as the 48w is a bit of a cut and shut panel all the wireless panels that ive fitted up to now have been 48 metals with wireless expanders or 24 plastics with wireless expanders all i know is expander 1 on a 48w is the inbuilt wireless part.
Thanks M8, not got a clue now. I think I got to clear the fault on EXP 1,1 before it will let me learn devices too.

I've sent off an e-mail to support to see if they can shed any light. I've also registered on their forum but waiting to be authorised before I can post.
tamper on a expander shouldnt stop you learning a device to the panel, can you gey into engineer mode and engineer utils ?
I can get into adding devices and follow the countdown from 20 but no devices are found. i have tried it with 4 different devices, didn't see the point in trying the other 3 :LOL:

Holding down the button whilst applying power to the device and waiting for it to be found :unsure:

Going to give up for the night.

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.

Are you a trade or supplier? You can create your listing free at DIYnot Local

Sponsored Links