Thermecon Oil Fired Boiler Instant Lockout issue (Ecoflam Minor?)

7 Feb 2016
Reaction score
United Kingdom
Hi Team,
I wonder if someone may be able to help with the following issue.
The Thermecon boiler is approximately 15 years and in the main performs well.
Last year we had a problem with the spark generation to fire the burner. On inspection the HT leads seem to be arcing and the spark wasn't always appearing at the electrodes. I managed to "fix" the problem by insulating the HT leads near the electrodes and this seemed to sort the issue.
Move on one year and the boiler failed to fire about a week ago. The symptoms were that on start up there didn't seem to be any sparking sound. On taking the burner off and quickly setting the boiler to run I could see that the was no spark being generated.
Move forward another two days and I have replaced the spark transformer, HT leads and what appeared to be the cause of the problem - the Electrode assembly. I think the insulation surrounding the two electrodes had broken down so much that it was shorting to earth which meant that there was no spark.
So, I thought I had sorted the problem. I put everything back together. Now when the boiler starts I hear the fan start, then the oil comes in and the spark kicks off. The fuel ignites and then immediately 5 or so seconds later, locks out.
Arh I thought. Had this before when the photo sensor was dirty. Took it out and it's as clean as a whistle. So I opened the burner hatch and saw one of the HT leads that I had replaced appeared to be covering the eye of the photo sensor. I was convinced that this was the issue. However, the same lockout problem results when I put it all back again.
So I took out the photo sensor and checked the resistance with a multi meter. This seems to register < 300 ohms in light so appears to be okay. I also let the boiler fire while the photo sensor was out and shone a bright light into it and still the lockout occurred.
So, to discount the possibility of the photo sensor causing the issue I wired, in parallel, a switch to short the terminals that the sensor is attached to. When the boiler fires I switch the switch so that there is effectively zero resistance but still the lockout occurs.
So now I am thinking it's either the control unit (Landis & Gyr / Siemens LOA24) or something else is causing the lockout out, but what?
I have even taken the control unit cover off and watched the gubbins inside the control unit. The bimetallic strip pulls across as expected on start up but the main solenoid on the right does not seem to energise. If during the firing process I physically push the solenoid contactor down then the boiler appears to continue to work as you would expect. On releasing the contactor the flame is lost but the oil pump is still running and I have to power off the boiler.
Now given all this, it seems to me that it's either a faulty control unit and at £55 a shot I am reluctant to replace just as a test, or something else other than the photo cell is not giving the feedback to the controller to allow combustion to continue.
Does anyone, from the symptoms described here know what the problem is?
From the spare parts I have purchased it appears that the burner is a Ecoflam Minor 1 or 4?
Any help would be greatly appreciated as it's cold!

Sponsored Links
Check the wiring form the photo cell for any cracks etc', this wire must be perfect, if not renew. Check that this wire is not in close contact or near to any other wires whatsover. Check the shielding of this wire (if any) and check the sheild continuity to earth, the faintest signal leak detection of any kind will void and trip the safety detection sequence.
Do not use any futher switches to short the cell as the signal which is present to confirm 'no flame' within the inition sequence will fail to safety, repeated shorting of the signal can cause irreversible damage to control box.
Do no further tests with 'light' as the characteristics of the ulraviolet spectrum are further up the scale. Only a carbonising flame, gas blue, oil yellow, etc' will have the characteristics to activate the cells function correctly.
Failing this, a new photoelectric cell may be required.
Mr. Therm,
Thanks for the quick reply.
Am I correct in assuming from your reply that there is nothing else at the stage of the sequence which I have been describing that can cause a lockout? If this is the case, then for the sake of a tenner I may as well try a new photo cell.
That's interesting about shorting the terminals will cause a fail safe (lockout). So there should be some residual resistance across those terminals even on a successful flame signal from the photo cell then?

Thanks again,

Re:- "The fuel ignites and then immediately 5 or so seconds later, locks out."

The above means the sequence is working o.k up until and during ignition, then after the few seconds detection time locks out due to "not detecting a flame".

Residual resistance? - throughout the sequence there is a monitored current passing through the cell telling the control box when there is a flame or when there is no flame.

A new cell is the key (or the associated wiring) as you have proved the box is still o.k. up until now at least, if a new cell doesn't work then only the control box is left suspect.

Air pressure has been proven.

Sponsored Links
Okay, I replaced the photo cell and the same issue exists, lockout after about 5 seconds.
Is there any other reason, before I shell out the best part of £40 on a new Landis control box, that the photo cell would not sense the flame? Can it be any flame? What if the flame is very yellow? I don't know why this would change since the boiler was working, as a week ago it was all fine.
Is it possible that since the sparking problem turned out to be dodgy electrode insulation, that by sparking to the chasis this has somehow fried some components in the control unit? I have had this apart and there really is no serviceable components inside or any fuse that I can see. I guess it's a case of trying a control unit and reporting back?
Thanks again,

Thanks for the link that is really helpful. I don't pretend to understand it all but there are a couple of key bits of information that have sort of helped.

1. The difference between QRB and QRC flame detectors. I have the former and it's merely a light cell. The QRC one is a blue flame detector which suggests to me that the presence of any flame should be enough to avoid a lockout using a QRB.

2. FR is a flame relay and when I took the control unit apart I held down the "solenoid" (Flame Relay) and the burner continued until I let go of the contact. This told me that if the relay energised all would have been okay. There is a Flame Signal Amplifier marked on the drawings (V) which I suspect needs to be working in order to activate the relay.

It does point more to a knackered controller so I will probably try a new unit. I will sleep on it tonight, but I can't see what else it can be. I am just hoping in a way that the HT problems did fry something in the controller which now means that the Flame Relay doesn't operate even when receiving the correct signal from the photo cell.

Really appreciate you sending the link and bothering to read all this. How did you find the circuit diagrams for the units?

Thanks again and will let you know how it goes, hopefully before the end of the week.


If you are using the pink QRB which is a high sensitivity cell then it may be detecting "false light" from the ignition. This will cause the LOA24 to pre-purge and then lock-out after 5 seconds. Try spinning the cell around to face away from the flame. Do this before changing control box.

Did you change the cell lead?
The QRB is the detector you need. Mr Therm has succeeded in muddying the waters. The Monoflame is not a blue flame burner and has no pressure proving system. Your boxis working in sequence if the burner lights and then locks out. The problem is in the photocell or thecircuitry ot the cell in the box. The time honoured way of testing photocells is to remove them, obscure them then shine a light on them when the burner lights. If it goes to lockout, then try a new cell, if the problem persists then its a new box.
oilhead, to be fair I don't think it was MrTherm who was muddying the waters, more likely me as I mentioned the two different light cell types. I was originally concerned that the photo cell may have needed to see a correctly burning flame and if not then that could cause a lockout. It seems with the QRB that it just needs to see light of some sort rather than a blue, correctly oxygenated flame. Given that I have now tried a new QRB with lead then and the same issue exists, absolutley no change, I suspect a knackered flame relay in the contol box. But I note Andy4444 comments and now wonder if, as the original problem was a lack of spark and now with a new ingintion transformer and electrodes the spark is bright and causing a false positive as soon as the ignition starts from the spark alone... but actually that won't matter will it, if the ignition sequence starts as soon as the oil starts as conceivably the flame could start instanteously? So even if a flame was seen from the spark alone, the sequence should move on?
If the box sees false light during pre purge, it will lock out when flame is established.
Terry, is that right? According to the documentation it says:-

Extraneous light / premature flame signal :
During the pre-purge time, no flame signal may be present.
If, however, a signal is delivered during this period of time, the LOA… locks out on expiry
of the pre-purge and safety time. Under these circumstances, the oil valve does not

If that is the case then presumably the burner wouldn't fire at all, which it is?

Last edited:
So, I went home at dinner time and tried the following:-

Took out the photocell from the burner housing.
Held it tightly in my hand (no light)
Started the boiler.
Waited for it to fire.
Put the photo cell back in its housing before the timeout time
The boiler locked out as if it didn't see a flame.

Then I tried the same process but instead of putting the photo cell back into its housing I offered up to a bright light.
The boiler locked out.
I have now bought a new control unit and will fit and re-test.

Well, I replaced the controller and what do you suppose happened? I turned on the boiler and there was a loud crack from the controller and it shot off its mounting and melted in the process leaving a trailing flame of molten plastic behind. The boiler insulation then caught fire but luckily I had a CO2 extinguisher to hand and managed to get most of the fire under control before the fire brigade turned up and hacked the boiler to pieces in the process of putting the fire out. Why did they need to do that?
No, of course that didn't happen, it just worked. Plugged in the new controller on the existing mounting, fired it up and away she went.
I can only guess that when the HT insulation went down a week ago that it took out some components on the controller which meant that the flame relay would not activate.
So we have heat and although I replaced perhaps more parts than were needed, at least I know that the ignition side of things is all new and should last another 15 years.
Thanks to all those that contributed, especially MrFlame and hopefully others will find this post useful when troubleshooting.
I did find a handy trouble shooting chart which I will post here when I find it again.

No offence was intended towards any Firemen out there.

Right from your opening post i could see you had that inquisitive trait and clear expressive style, just a gentle nudge in the right direction was all that was needed to sort out the problem yourself.

A great result AJ

Best regards to all participants.

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.

Are you a trade or supplier? You can create your listing free at DIYnot Local

Sponsored Links